• 人民日报客户端宣传页 2019-11-15
  • 一语惊坛(6月5日):担当新使命,展现新作为。 2019-11-15
  • 俄罗斯驻华大使:未来上合的首要任务是加强区域一体化 2019-11-14
  • 今后不懂藏文也能读《格萨尔》了 2019-11-14
  • 太原网友:谁来管管逢雨必淹的山大附小周边 2019-11-13
  • 拉萨市为第五批市级非遗代表性项目传承人颁证 2019-11-12
  • 商务部新闻发言人对美白宫6月18日声明发表谈话 2019-11-12
  • “袋鼠军团”宣称有秘密武器 老将新秀谁更耀眼? 2019-11-11
  • 他们是中国军人,他们2个月排除380万平方米雷场 2019-11-07
  • 陕西守艺人丨传承自父亲的老油坊,是我人生的希望之光 2019-11-04
  • 人民日报评论:在端午品味文化的芳香 2019-11-04
  • 广东摧毁两“呼死你”团伙 恶意呼叫超过12亿次 2019-11-03
  • 400年来旷日持久的一桩公案:《西游记》作者真的是吴承恩吗? 2019-11-03
  • 紫光阁中共中央国家机关工作委员会 2019-11-03
  • “普京4.0”时代 三大执政优势应对挑战 2019-11-02
  • 首页 > 编程学习记录 > 易语言传送支持库:提示“无法获得文件大小”

    201612月20

    易语言传送支持库:提示“无法获得文件大小”

    作者:admin 0 Comments 发表评论

    曾道人新报跑狗 www.jmuag.tw 明明是按照教程来写的代码,但是提示“无法获得文件大小”,然后就没有然后了,直接停止了下载。测试发现如果是下载MP3、exe等的链接没有问题,但是下载HTML文件时有问题,下面是截图和代码:

    提示:无法获取文件大小

    //pan.baidu.com/s/1bpgOQQV

    如果不愿意下载,可以直接复制下面的:

    .版本 2
    .支持库 downlib
    .支持库 spec

    .程序集 窗口程序集_启动窗口
    .程序集变量 下载对象, 下载对象
    .程序集变量 配置信息, 任务参数

    .子程序 _按钮1_被单击

    配置信息.类型 = #传送常量.下载

    配置信息.文件地址 = “//im.qq.com/”
    配置信息.本地文件路径 = “F:\99.html”
    配置信息.默认线程数 = 1
    配置信息.连接超时 = 20000
    配置信息.发送超时 = 20000
    配置信息.接收超时 = 20000
    配置信息.下载速度 = 0

    配置信息.日志回调函数 = &日志回调函数子程序 ‘ 测试可以不用
    配置信息.交互回调函数 = &交互回调函数子程序 ‘ 必须要有
    下载对象.增加新任务 (配置信息)
    .子程序 日志回调函数子程序
    .参数 线程信息, 整数型
    .参数 消息产生的时间, 文本型
    .参数 消息的正文, 文本型
    .参数 消息类型, 整数型
    .参数 对象信息, 整数型

    调试输出 (消息的正文)
    .子程序 交互回调函数子程序
    .参数 消息类型, 整数型
    .参数 线程信息, 整数型
    .参数 第三个参数, 整数型
    .参数 第四个参数, 整数型
    .参数 对象信息, 整数型
    调试输出 (消息类型)

    补充:通过经过进一步测试,如果下载的网页是纯静态页面,就可以正常下载,如果是伪静态或者动态页面,就不能正常下载,都是提示无法获取文件大小,然后就停止了下载。用“HTTP读文件”倒是可以下载正常,但是这样就没法获取到下载进度等信息。

    用HTTP下载的方式写的多线程的源码:

    //pan.baidu.com/s/1miBEHXe

    推荐阅读相关文章:编程学习记录

    本文地址://www.jmuag.tw/chuansongzhichiku.html
    版权所有 © 转载时必须以链接形式注明作者和原始出处!

    本文目前尚无任何评论.

    发表评论

  • 人民日报客户端宣传页 2019-11-15
  • 一语惊坛(6月5日):担当新使命,展现新作为。 2019-11-15
  • 俄罗斯驻华大使:未来上合的首要任务是加强区域一体化 2019-11-14
  • 今后不懂藏文也能读《格萨尔》了 2019-11-14
  • 太原网友:谁来管管逢雨必淹的山大附小周边 2019-11-13
  • 拉萨市为第五批市级非遗代表性项目传承人颁证 2019-11-12
  • 商务部新闻发言人对美白宫6月18日声明发表谈话 2019-11-12
  • “袋鼠军团”宣称有秘密武器 老将新秀谁更耀眼? 2019-11-11
  • 他们是中国军人,他们2个月排除380万平方米雷场 2019-11-07
  • 陕西守艺人丨传承自父亲的老油坊,是我人生的希望之光 2019-11-04
  • 人民日报评论:在端午品味文化的芳香 2019-11-04
  • 广东摧毁两“呼死你”团伙 恶意呼叫超过12亿次 2019-11-03
  • 400年来旷日持久的一桩公案:《西游记》作者真的是吴承恩吗? 2019-11-03
  • 紫光阁中共中央国家机关工作委员会 2019-11-03
  • “普京4.0”时代 三大执政优势应对挑战 2019-11-02
  • 河北十一选五开奖结果 极速11选5微信计划群 海南环岛赛路线 福彩双色球号码预测 北京赛车独胆一码技巧 二分彩殺号 河北十一选五走势图 pk10牛牛玩法介绍 广东十一选五视频直播 中国福利彩票网