• 世界杯相关保险:ATM提款被抢可理赔 2019-09-18
  • “三连冠”从何而来?恩施市领跑全省生态功能类县市揭秘 2019-09-16
  • 朝鲜军人敬了一个礼 特朗普看到后马上回了一个 2019-09-16
  • 北京市北京元之沃4S店【在线咨询】 2019-09-06
  • 指尖触碰 你我结缘丨浙江新闻4周年 我们再出发 2019-09-06
  • 聚焦十九大 专家解读:中国的大国外交彰显哪些理念? 2019-09-01
  • 【聚焦军博会】216个代表团2037个项目将亮相军博会 11大军工集团全部参展 2019-09-01
  • 聚焦机构改革:新部门接连挂牌 快速进入角色 2019-08-28
  • 二手房办证5个工作日搞定 2019-08-28
  • 218万游客在晋中市“粽”情过节 2019-08-22
  • 西安6月以来限购区域内无一家开盘,“摇号细则近日将出” ——凤凰网房产北京 2019-08-22
  • 晓港公园花卉馆南侧场地出租项目 2019-08-21
  • “三个90周年”系列秋收起义90周年纪念活动新闻发布会在昌召开 2019-08-11
  • 打造历史文化名城 “安宁记忆”项目启幕 2019-08-11
  • 罗品禧的专栏作者中国国家地理网 2019-08-10
  • 首页 > 编程学习记录 > 易语言传送支持库:提示“无法获得文件大小”

    201612月20

    易语言传送支持库:提示“无法获得文件大小”

    作者:admin 0 Comments 发表评论

    曾道人新报跑狗 www.jmuag.tw 明明是按照教程来写的代码,但是提示“无法获得文件大小”,然后就没有然后了,直接停止了下载。测试发现如果是下载MP3、exe等的链接没有问题,但是下载HTML文件时有问题,下面是截图和代码:

    提示:无法获取文件大小

    //pan.baidu.com/s/1bpgOQQV

    如果不愿意下载,可以直接复制下面的:

    .版本 2
    .支持库 downlib
    .支持库 spec

    .程序集 窗口程序集_启动窗口
    .程序集变量 下载对象, 下载对象
    .程序集变量 配置信息, 任务参数

    .子程序 _按钮1_被单击

    配置信息.类型 = #传送常量.下载

    配置信息.文件地址 = “//im.qq.com/”
    配置信息.本地文件路径 = “F:\99.html”
    配置信息.默认线程数 = 1
    配置信息.连接超时 = 20000
    配置信息.发送超时 = 20000
    配置信息.接收超时 = 20000
    配置信息.下载速度 = 0

    配置信息.日志回调函数 = &日志回调函数子程序 ‘ 测试可以不用
    配置信息.交互回调函数 = &交互回调函数子程序 ‘ 必须要有
    下载对象.增加新任务 (配置信息)
    .子程序 日志回调函数子程序
    .参数 线程信息, 整数型
    .参数 消息产生的时间, 文本型
    .参数 消息的正文, 文本型
    .参数 消息类型, 整数型
    .参数 对象信息, 整数型

    调试输出 (消息的正文)
    .子程序 交互回调函数子程序
    .参数 消息类型, 整数型
    .参数 线程信息, 整数型
    .参数 第三个参数, 整数型
    .参数 第四个参数, 整数型
    .参数 对象信息, 整数型
    调试输出 (消息类型)

    补充:通过经过进一步测试,如果下载的网页是纯静态页面,就可以正常下载,如果是伪静态或者动态页面,就不能正常下载,都是提示无法获取文件大小,然后就停止了下载。用“HTTP读文件”倒是可以下载正常,但是这样就没法获取到下载进度等信息。

    用HTTP下载的方式写的多线程的源码:

    //pan.baidu.com/s/1miBEHXe

    推荐阅读相关文章:编程学习记录

    本文地址://www.jmuag.tw/chuansongzhichiku.html
    版权所有 © 转载时必须以链接形式注明作者和原始出处!

    本文目前尚无任何评论.

    发表评论

  • 世界杯相关保险:ATM提款被抢可理赔 2019-09-18
  • “三连冠”从何而来?恩施市领跑全省生态功能类县市揭秘 2019-09-16
  • 朝鲜军人敬了一个礼 特朗普看到后马上回了一个 2019-09-16
  • 北京市北京元之沃4S店【在线咨询】 2019-09-06
  • 指尖触碰 你我结缘丨浙江新闻4周年 我们再出发 2019-09-06
  • 聚焦十九大 专家解读:中国的大国外交彰显哪些理念? 2019-09-01
  • 【聚焦军博会】216个代表团2037个项目将亮相军博会 11大军工集团全部参展 2019-09-01
  • 聚焦机构改革:新部门接连挂牌 快速进入角色 2019-08-28
  • 二手房办证5个工作日搞定 2019-08-28
  • 218万游客在晋中市“粽”情过节 2019-08-22
  • 西安6月以来限购区域内无一家开盘,“摇号细则近日将出” ——凤凰网房产北京 2019-08-22
  • 晓港公园花卉馆南侧场地出租项目 2019-08-21
  • “三个90周年”系列秋收起义90周年纪念活动新闻发布会在昌召开 2019-08-11
  • 打造历史文化名城 “安宁记忆”项目启幕 2019-08-11
  • 罗品禧的专栏作者中国国家地理网 2019-08-10
  • 极速时时计划13458 重庆时时彩后三基本走势图 彩v8彩票app 老时时走势图 时时彩开彩最新结果查询 vr彩票开奖走势图 青鹏棋牌 菲律宾知名彩票盘 重庆快乐10分官网 香港49选7历年开奖结果