• 滨河西路南延工程进入路基施工阶段 2019-07-19
  • 《中国独角兽企业价值榜》和《中国瞪羚企业价值榜》发布 2019-07-19
  • 闪崩股有点多!每个背后都有个质押爆仓的惊心故事,这51股质押比例超60% 2019-07-13
  • 中国保险行业协会发布汽车后市场配件合车标准 2019-07-09
  • 切切切,端午节安康! 2019-07-09
  • 探索西部引才用才新机制 打造四川转型发展新引擎 2019-07-03
  • 女性之声——全国妇联 2019-06-28
  • 中共中央政治局集体学习 2019-06-26
  • 宝马、MINI与劳斯莱斯多款车型召回 共涉及5829辆 2019-06-26
  • 镇江破部督最大骗取出口退税案 2019-06-24
  • 海军第二十九批护航编队滨州舰技术停靠西班牙 2019-06-24
  • 段健的专栏作者中国国家地理网 2019-06-24
  • 马克思主义哲学是帮助我们看清世界的一双“慧眼” 2019-06-23
  • 外卖小哥选择为生命“引航”,网友疯狂点赞… 2019-06-19
  • 匹夫有责之一百一十三—道义大义的博客—强国博客—人民网 2019-06-19
  • 首页 > 编程学习记录 > 易语言传送支持库:提示“无法获得文件大小”

    201612月20

    易语言传送支持库:提示“无法获得文件大小”

    作者:admin 0 Comments 发表评论

    曾道人新报跑狗 www.jmuag.tw 明明是按照教程来写的代码,但是提示“无法获得文件大小”,然后就没有然后了,直接停止了下载。测试发现如果是下载MP3、exe等的链接没有问题,但是下载HTML文件时有问题,下面是截图和代码:

    提示:无法获取文件大小

    //pan.baidu.com/s/1bpgOQQV

    如果不愿意下载,可以直接复制下面的:

    .版本 2
    .支持库 downlib
    .支持库 spec

    .程序集 窗口程序集_启动窗口
    .程序集变量 下载对象, 下载对象
    .程序集变量 配置信息, 任务参数

    .子程序 _按钮1_被单击

    配置信息.类型 = #传送常量.下载

    配置信息.文件地址 = “//im.qq.com/”
    配置信息.本地文件路径 = “F:\99.html”
    配置信息.默认线程数 = 1
    配置信息.连接超时 = 20000
    配置信息.发送超时 = 20000
    配置信息.接收超时 = 20000
    配置信息.下载速度 = 0

    配置信息.日志回调函数 = &日志回调函数子程序 ‘ 测试可以不用
    配置信息.交互回调函数 = &交互回调函数子程序 ‘ 必须要有
    下载对象.增加新任务 (配置信息)
    .子程序 日志回调函数子程序
    .参数 线程信息, 整数型
    .参数 消息产生的时间, 文本型
    .参数 消息的正文, 文本型
    .参数 消息类型, 整数型
    .参数 对象信息, 整数型

    调试输出 (消息的正文)
    .子程序 交互回调函数子程序
    .参数 消息类型, 整数型
    .参数 线程信息, 整数型
    .参数 第三个参数, 整数型
    .参数 第四个参数, 整数型
    .参数 对象信息, 整数型
    调试输出 (消息类型)

    补充:通过经过进一步测试,如果下载的网页是纯静态页面,就可以正常下载,如果是伪静态或者动态页面,就不能正常下载,都是提示无法获取文件大小,然后就停止了下载。用“HTTP读文件”倒是可以下载正常,但是这样就没法获取到下载进度等信息。

    用HTTP下载的方式写的多线程的源码:

    //pan.baidu.com/s/1miBEHXe

    推荐阅读相关文章:编程学习记录

    本文地址://www.jmuag.tw/chuansongzhichiku.html
    版权所有 © 转载时必须以链接形式注明作者和原始出处!

    本文目前尚无任何评论.

    发表评论

  • 滨河西路南延工程进入路基施工阶段 2019-07-19
  • 《中国独角兽企业价值榜》和《中国瞪羚企业价值榜》发布 2019-07-19
  • 闪崩股有点多!每个背后都有个质押爆仓的惊心故事,这51股质押比例超60% 2019-07-13
  • 中国保险行业协会发布汽车后市场配件合车标准 2019-07-09
  • 切切切,端午节安康! 2019-07-09
  • 探索西部引才用才新机制 打造四川转型发展新引擎 2019-07-03
  • 女性之声——全国妇联 2019-06-28
  • 中共中央政治局集体学习 2019-06-26
  • 宝马、MINI与劳斯莱斯多款车型召回 共涉及5829辆 2019-06-26
  • 镇江破部督最大骗取出口退税案 2019-06-24
  • 海军第二十九批护航编队滨州舰技术停靠西班牙 2019-06-24
  • 段健的专栏作者中国国家地理网 2019-06-24
  • 马克思主义哲学是帮助我们看清世界的一双“慧眼” 2019-06-23
  • 外卖小哥选择为生命“引航”,网友疯狂点赞… 2019-06-19
  • 匹夫有责之一百一十三—道义大义的博客—强国博客—人民网 2019-06-19
  • 江西多乐彩11选5遗漏 快乐8开奖历史 孙悟空在线客服 陕西快乐10分开奖直播现场 天天捕鱼安卓版下载 古怪猴子网站 热刺足球俱乐部二队 黑龙江快乐十分走势图一定牛 忍者法宝投注 南粤36选7中奖规则